Degraded performance in web and mobile applications

Incident Report for GoSpotCheck

Resolved

This incident has been resolved.
Posted Mar 15, 2021 - 15:09 MDT

Update

PhotoWorks has stabilized, we are closely monitoring all systems
Posted Mar 15, 2021 - 12:47 MDT

Monitoring

Web and mobile API traffic has stabilized. We are now investigating a cascading problem that is preventing PhotoWorks from loading
Posted Mar 15, 2021 - 12:40 MDT

Update

We are continuing to work on a fix for this issue.
Posted Mar 15, 2021 - 12:11 MDT

Identified

Mobile API traffic has stabilized. We are investigating an issue with a "403 Forbidden" error affecting the web dashboard
Posted Mar 15, 2021 - 12:05 MDT

Update

A fix has been implemented and we are monitoring the results.
Posted Mar 15, 2021 - 11:46 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 15, 2021 - 11:45 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 15, 2021 - 09:52 MDT

Investigating

We are currently investigating performance issues accessing the web application and mobile APIs
Posted Mar 15, 2021 - 09:15 MDT
This incident affected: Mobile Client Applications (iOS, Android) and Web Application, PhotoWorks.