Mobile sign-in issues
Incident Report for GoSpotCheck
Postmortem

On June 11th, GoSpotCheck released an update to a backend service that powers our mission availability functionality. An issue in this service resulted in an unexpected error code to be returned to an upstream service used by the mobile applications for general authentication and data transfer. This resulted in the service returning a 401 unauthorized error code back to the mobile clients, which in turn logged the users out.

Due to the nature of the issue, it was not possible to sign back in as upon first page load in the mobile application, the 401 condition would immediately be triggered again.

GoSpotCheck engineers identified the source of the issue, and rolled back the service deployment causing the issue, which immediately restored login functionality for all mobile users.

Posted 25 days ago. Jun 26, 2019 - 14:28 MDT

Resolved
We are investigating reports of mobile users being unable to sign-in to the application and instead getting into a sign-in loop
Posted about 1 month ago. Jun 11, 2019 - 14:30 MDT