We have gotten word that our data service provider is reporting full restoration of health as of 21:18 UTC. We are moving this incident to a monitoring state and will continue to observe for the remainder of the day
Posted Oct 20, 2025 - 16:08 MDT
Update
AWS is reporting continued recovery of their computing services. We are observing better query performance and availability across the GSC Insights platform, but are continuing to monitor. We will provide further updates once AWS has fully mitigated their incident.
Posted Oct 20, 2025 - 14:07 MDT
Update
Amazon is continuing to work towards mitigation of their infrastructure issues. We are monitoring their progress and will provide further updates as they are available.
Posted Oct 20, 2025 - 10:22 MDT
Identified
We are investigating performance issues and delays in loading dashboards in GoSpotCheck insights as a result of this morning's outages in AWS us-east-1 region. https://health.aws.amazon.com/health/status
We will provide updates on the status as AWS works to restore service