Degraded performance in mobile applications
Incident Report for GoSpotCheck
Resolved
This incident has been resolved.
Posted May 01, 2020 - 09:21 MDT
Monitoring
GoSpotCheck has just released the latest version of the Android application to the Google Play store (5.0.0), which includes a workaround fix for the Maps crash. This release will take some time to propagate through the Play store, so please update to it as soon as it is available to you.

We will continue to monitor crash rates as this release is adopted and as Google continues to take action on their end to mitigate the crashes.

Instructions on how to download the latest version of the GoSpotCheck application are available here: https://support.gospotcheck.com/hc/en-us/articles/220795107-Downloading-the-App
Posted Apr 29, 2020 - 11:14 MDT
Update
Google has provided updated guidance that the full rollout of their fix for the crash issues will take longer than their originally promised 48 hours, and is recommending application developers implement a workaround in the meantime. GoSpotCheck is currently looking into implementing such a workaround in our next planned release.

As of right now, the only workaround for continued Android crashes is to clear application data and cache and reload the app, although this will delete any in-progress missions. Instructions for how to clear cache and data are available here: https://support.gospotcheck.com/hc/en-us/articles/235543287-How-to-Clear-Cache-and-Data-Android

Latest updates are available from Google's issue tracker here: https://issuetracker.google.com/issues/154855417
Posted Apr 27, 2020 - 11:28 MDT
Identified
As of last night, the Google Maps issue causing crashes on iOS has been resolved.

Google continues to work towards resolution of crashes on Android with a promised ETA for fix within 48 hours. In the meantime, a viable workaround is to clear cache and data and reload the app, although this will delete any in-progress missions. Instructions for how to clear cache and data are available here: https://support.gospotcheck.com/hc/en-us/articles/235543287-How-to-Clear-Cache-and-Data-Android

Latest updates are available from Google's issue tracker here: https://issuetracker.google.com/issues/154855417
Posted Apr 24, 2020 - 08:03 MDT
Update
Google is rolling out a fix for the Maps SDK that is causing widespread crashes in mobile applications that make use of the component, such as GoSpotCheck. According to their latest status update, the full resolution is expected for iOS as of approximately 30 minutes ago, with full resolution for Android expected by 10:45pm pacific time.

Additional details on the issue available here: https://issuetracker.google.com/issues/154855417#comment215
Posted Apr 23, 2020 - 21:08 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 23, 2020 - 19:03 MDT
Identified
Degraded performance in the mobile applications due to a 3rd party vendor issue.
Posted Apr 23, 2020 - 16:15 MDT
This incident affected: Mobile Client Applications (iOS, Android).