PhotoWorks Unavailable
Incident Report for GoSpotCheck
Resolved
Primary functionality for PhotoWorks has been restored as of 13:31 MDT. GoSpotCheck engineering will be continuing to work through maintenance activities in the background to restore the remaining system back to normal operating parameters.
Posted Apr 14, 2021 - 19:50 MDT
Monitoring
We have worked with our data store vendor to partially restore service. PhotoWorks is now available, but there may still be some pages that fail to load, or load slower than normal. Full mitigation efforts are still ongoing.
Posted Apr 14, 2021 - 13:31 MDT
Identified
We are taking steps to mitigate the unavailability of the data store that powers the PhotoWorks application, with the guidance of our vendor. We will provide another update in 60 minutes.
Posted Apr 14, 2021 - 12:48 MDT
Update
We are continuing to work with our data store vendor to identify the root cause of the issue impacting PhotoWorks. Next update will be provided in 60 minutes
Posted Apr 14, 2021 - 10:56 MDT
Update
We are continuing to work with our data store vendor to identify the root cause of the issue impacting PhotoWorks. Next update will be provided in 60 minutes
Posted Apr 14, 2021 - 09:42 MDT
Update
PhotoWorks is currently unavailable, and our team is working with our data store vendor to resolve the issue as soon as possible. Mobile application users can still complete and submit missions that include photo tasks. For PhotoWorks users, all images submitted will sync into PhotoWorks once the issue is corrected.
Posted Apr 14, 2021 - 08:29 MDT
Investigating
We are investigating an issue with the PhotoWorks application.
Posted Apr 14, 2021 - 06:39 MDT
This incident affected: PhotoWorks.