Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 01, 2020 - 22:01 MST
Update
This maintenance has been postponed to Sunday, November 1st from 10pm-12am MST
Posted Oct 28, 2020 - 21:21 MDT
Scheduled
On Wednesday, October 28th from 10pm-12a MDT, our infrastructure partner will be performing scheduled maintenance on our Insights platform to deploy feature updates. Insights will be intermittently unavailable during this planned maintenance.